你的分享就是我们的动力 ---﹥

解决Eclipse Maven插件的最佳方案

时间:2014-11-11 14:10来源:www.chengxuyuans.com 点击:

  最近在尝试使用GAE,要求项目必须使用Maven,于是下载了Maven3.1.1配置了环境变量。但是在为Eclipse EE安装Maven插件的时候遇到了问题。

  官网的建议是:

  1. 在Eclipse EE中选择Help->Install New Software->Add
  2. 在Location一栏输入https://www.eclipse.org/m2e/,Name可以自己命名(比如M2Eclipse)
  3. 选中要安装的Maven插件,install

  但是这样做很可能会遇到这样的问题cannot complete the install because one or more required items could not be found。原因应该是缺少安装Maven插件所依赖的另一些jar包,在StackOverFolw上给出了这样的解决方案:

  1. Help -> Install New Software
  2. 在Location一栏输入http://www.fuin.org/p2-repository/,Name可以自己命名(比如slf4j)
  3. 展开 "Maven osgi-bundles" 选中 "slf4j-api"
  4. 之后按照官网的建议重新安装M2Eclipse插件

  我参照上面的思路做了,我的Eclipse版本是JUNO,并没有奏效,安装M2Eclipse的时候依然会遇到问题,有说其他版本不会遇到问题。于是我就去eclipse的官网尝试去看下其他版本,结果惊奇地发现Luna和Mars版本的Eclipse EE自带了对Maven的支持!所以最好的解决方案就是Upgrade你的Eclipse。那么具体应该怎么做呢?在同一版本的Eclipse中进行升级,可以Help->Check for updates就行了,但是如果想从JUNO升级为Luna应该怎么办呢?

  Eclipse问答区建议是:

  1. 添加新版本的仓库
    1. Window > Preferences > Install/Update > Available Software Sites
    2. 点击 'Add'
    3. 输入新版本仓库的Url (比如想升级为Luna版本, 输入http://download.eclipse.org/releases/luna/)
    4. 点击 'Ok'
  2. Help > Check for Updates
  3. 完成之后点击finish,然后会提醒restart eclipse,确认就可以了。

  使用这种方式升级Eclipse个人觉得是最好的,虽然也可以直接下载新版本解压,然后选择原来的workspace就可以了,但是可能之前下载的一些插件也就没有了,需要重新安装。升级Eclipse的同时解决了Maven插件无法安装的问题,个人觉得是最好的解决方案,毕竟新版本的Eclipse能给你提供更多帮助,你迟早也会需要它的。

转载注明地址:http://www.chengxuyuans.com/javabase/84411.html